风萧萧兮易水寒

易语言对接腾讯ai智能闲聊

介绍

腾讯闲聊服务基于AI Lab领先的NLP引擎能力、数据运算能力和千亿级互联网语料数据的支持,同时集成了广泛的知识问答能力,可实现上百种自定义属性配置,以及男、女不同的语言风格及说话方式,从而让聊天变得更睿智、简单和有趣

基础闲聊接口提供基于文本的基础聊天能力,可以让您的应用快速拥有具备上下文语义理解的机器聊天功能。

注:同时我将此接口制作成插件,可以应用在QQ和微信上。再也不怕自己一个人没人聊天了。

准备

首先在腾讯ai官网注册自己的账号,将智能闲聊接入。然后在控制台-应用管理,找到刚接入的智能闲聊,在应用信息里面得到APPID,APPKEY两个参数。
首页

基础闲聊API地址:

https://api.ai.qq.com/fcgi-bin/nlp/nlp_textchat

入参:

image

编写代码

getAI 方法

注意: #app_id#app_key 就是上面申请得到的两个参数

.版本 2

.子程序 getAI, , 公开
.参数 msg, 文本型, , 消息内容
.局部变量 入参, 文本型
.局部变量 time_stamp, 文本型
.局部变量 nonce_str, 文本型
.局部变量 session, 文本型
.局部变量 question, 文本型
.局部变量 sign, 文本型
.局部变量 反参, 文本型
.局部变量 JSON, 类_json
.局部变量 回复消息, 文本型

msg = 删全部空 (msg)
' 限制问题字数不能超过250字节 ,官方要求:非空且长度上限300字节
.如果真 (取文本长度 (msg) > 250)
    返回 ()
.如果真结束

time_stamp = 时间_取现行时间戳 (真)
nonce_str = 文本_取随机字符 (16)
session = nonce_str
question = 编码_URL编码 (编码_gb2312到utf8 (msg), 真, )
入参 = “app_id=” + #app_id + “&nonce_str=” + nonce_str + “&question=” + question + “&session=” + session + “&time_stamp=” + time_stamp
' 入参一定要按照字典顺序排好,不然签名不对
sign = getSign (入参)
入参 = 入参 + “&sign=” + sign
反参 = 编码_utf8到gb2312 (网页_访问S (“https://api.ai.qq.com/fcgi-bin/nlp/nlp_textchat”, 1, 入参, , , , , , , , , , , , , , , , , , ))

.如果真 (JSON.解析 (反参))
    .如果真 (JSON.取通用属性 (“ret”, ) = “0”)
        回复消息 = JSON.取通用属性 (“data.answer”, )
        .如果真 (回复消息 ≠ “”)
            ' 得到智能ai的回答之后,做你想做的事情
        .如果真结束

    .如果真结束

getSign 方法

.版本 2

.子程序 getSign, 文本型
.参数 入参, 文本型


返回 (校验_取md5 (到字节集 (入参 + “&app_key=” + #app_key), 真, ))

结束

最后还可以在腾讯ai控制台中配置多重属性的闲聊画像,并且可配置的属性会持续增加,使闲聊的风格因您的喜好而不同。
可以实时观看应用概况
image

坚持原创技术分享,您的支持将鼓励我继续创作!
  • 本文作者: GMaya
  • 本文链接: https://gmaya.top/2020/0307/
  • 版权声明: 本博客所有文章除特别声明外,均采用 BY-NC-SA 许可协议。转载请注明出处!